Screenful app is unavailable
Incident Report for Screenful
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 01:56 EEST
Identified
We have identified the issue, which is now being investigated by our platform provider.
Posted Oct 08, 2024 - 21:15 EEST
Investigating
We are currently investigating this issue.
Posted Oct 08, 2024 - 20:33 EEST
This incident affected: Screenful app, Atlassian add-on for JIRA Cloud, and Screenful API.