Trello dashboards are not automatically updated hourly (only daily)
Incident Report for Screenful
Resolved
This incident has been resolved.
Posted 22 days ago. Aug 01, 2019 - 13:56 EEST
Investigating
We're currently investigating the issue.
Posted 22 days ago. Aug 01, 2019 - 12:18 EEST
This incident affected: Screenful app.